IModelProps Interface
Properties of an iModel that are always held in memory whenever one is opened, both on the frontend and on the backend .
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
ecefLocation | undefined | EcefLocationProps | The location of the iModel in Earth Centered Earth Fixed coordinates. | |
geographicCoordinateSystem | undefined | GeographicCRSProps | The Geographic Coordinate Reference System indicating the projection and datum used. | |
globalOrigin | undefined | XYZProps | An offset to be applied to all spatial coordinates. | |
name | undefined | string | The name of the iModel. | |
projectExtents | undefined | Range3dProps | The volume of the entire project, in spatial coordinates | |
rootSubject | RootSubjectProps | The name and description of the root subject of this iModel |
Defined in
- core/common/src/IModel.ts Line 80
Last Updated: 11 June, 2024