SchemaState Enumeration

Beta  

The state of the schemas in the Db compared with what the current version of the software expects Note: The state may vary depending on whether the Db is to be opened ReadOnly or ReadWrite.

Members

Name Value Description
UpToDate 0 The schemas in the Db are up-to-date, and do not need to be upgraded before opening it with the current version of the software
UpgradeRequired 1 It's required that the schemas in the Db be upgraded before it can be opened with the current version of the software.
This may happen in read-write scenarios where the application requires a newer version of the schemas to be in place before
it can write data based on that new schema.
UpgradeRecommended 2 It's recommended, but not necessary that the schemas in the Db be upgraded before opening it with the current version of the software
TooOld 3 The schemas in the Db are too old to be opened by the current version of the software. Upgrade using the API is not possible.
TooNew 4 The schemas in the Db are too new to be opened by the current version of the software

Defined in

Last Updated: 29 November, 2022