FeatureAppearance Class

Defines overrides for selected aspects of a Feature's symbology. Any member defined in the appearance overrides that aspect of symbology for all Features to which the appearance is applied.

see FeatureOverrides to customize the appearance of multiple features.

Implements

Methods

Name Description
constructor(props: FeatureAppearanceProps): FeatureAppearance Protected    
clone(changedProps: FeatureAppearanceProps): FeatureAppearance Create a copy of this appearance, overriding any properties explicitly specified by changedProps.  
cloneProps(changedProps: FeatureAppearanceProps): FeatureAppearanceProps Convert this appearance to JSON, and override any properties explicitly specified by changedProps in the result.  
equals(other: FeatureAppearance): boolean    
extendAppearance(base: FeatureAppearance): FeatureAppearance Produce a FeatureAppearance from the supplied appearance in which any aspect not defined by the base appearance is overridden by this appearance.  
toJSON(): FeatureAppearanceProps    
fromJSON(props?: FeatureAppearanceProps): FeatureAppearance Static    
fromRgb(color: ColorDef): FeatureAppearance Static Create a FeatureAppearance that overrides only the RGB color.  
fromRgba(color: ColorDef): FeatureAppearance Static Create a FeatureAppearance that overrides the RGB and transparency.  
fromSubCategoryOverride(ovr: SubCategoryOverride): FeatureAppearance Static Create a FeatureAppearance with overrides corresponding to those defined by the supplied SubCategoryOverride.  
fromTransparency(transparencyValue: number): FeatureAppearance Static Create a FeatureAppearance that overrides only the transparency  

Properties

Name Type Description
anyOverridden Accessor ReadOnly boolean Returns true if any aspect of the appearance is overridden (i.e., if any member is not undefined).  
defaults StaticReadonly FeatureAppearance An appearance that overrides nothing.  
emphasized Readonly undefined | "true" If true, the associated Feature will be emphasized.  
ignoresMaterial Readonly undefined | "true" If true, ignore the RenderMaterial associated with surfaces.  
isFullyTransparent Accessor ReadOnly boolean    
linePixels Readonly undefined | LinePixels The pixel pattern used to draw lines.  
matchesDefaults Accessor ReadOnly boolean Returns true if this appearance does not override any aspects of symbology.  
nonLocatable Readonly undefined | "true" If true, the associated Feature will not be drawn when using Viewport.readPixels.  
overridesLinePixels Accessor ReadOnly boolean    
overridesNonLocatable Accessor ReadOnly boolean    
overridesRgb Accessor ReadOnly boolean    
overridesSymbology Accessor ReadOnly boolean    
overridesTransparency Accessor ReadOnly boolean    
overridesWeight Accessor ReadOnly boolean    
rgb Readonly undefined | RgbColor The color of the Feature  
transparency Readonly undefined | number The transparency in the range [0.0, 1.0] where 0 indicates fully opaque and 1 indicates fully transparent.  
weight Readonly undefined | number The line weight in pixels as an integer in [1, 31]  

Defined in

Last Updated: 29 November, 2022