RpcOperationPolicy Class

The policy for an RPC operation.

Methods

Name Description
constructor(): RpcOperationPolicy    

Properties

Name Type Description
allowResponseCaching RpcResponseCachingCallback_T Determines if caching is permitted for an operation response.  
allowTokenMismatch boolean Whether the IModelRpcProps in the operation parameter list is allowed to differ from the token in the request URL.  
forceStrictMode boolean Forces RpcConfiguration.strictMode for this operation.  
invocationCallback RpcInvocationCallback_T Called for every operation invocation on the backend.  
requestCallback RpcRequestCallback_T Called before every operation request on the frontend is sent.  
retryInterval RpcRequestInitialRetryIntervalSupplier_T Supplies the initial retry interval for an operation request.  
sentCallback RpcRequestCallback_T Called after every operation request on the frontend is sent.  
token RpcRequestTokenSupplier_T Supplies the IModelRpcProps for an operation request.  

Defined in

Last Updated: 29 November, 2022