RpcRequestContext Interface

Interface to enable passing application-specific context with each RPC request.

Methods

Name Description
deserialize(request: SerializedRpcRequest): Promise<ClientRequestContext> Used at backend to deserialize client specified context  
getId(request: RpcRequest<any>): string Used to get the id of the request at the frontend  
serialize(request: RpcRequest<any>): Promise<SerializedClientRequestContext> Used at frontend to serialize client specified context  

Defined in

Last Updated: 29 November, 2022