ThematicGradientSettingsProps Interface

JSON representation of a ThematicGradientSettings.

Properties

Name Type Description
colorMix undefined | number The percentage to mix in the original color with the thematic display gradient color (0-1).  
colorScheme undefined | ThematicGradientColorScheme The color scheme used to generate the colors of the gradient within the applied range.  
customKeys undefined | Gradient.KeyColorProps[] The key color values that must be provided when using a custom thematic color scheme.  
marginColor undefined | number The margin color used at the extremes of the gradient, when outside the applied range.  
mode undefined | ThematicGradientMode The thematic image mode used to generate and apply the thematic gradient.  
stepCount undefined | number The step count value used for ThematicGradientMode.Stepped, ThematicGradientMode.SteppedWithDelimiter, and ThematicGradientMode.IsoLines.  

Defined in

Last Updated: 29 November, 2022