Extension Class

Base Extension class for writing a demand-loaded module.

see ExtensionAdmin for a description of how Extensions are loaded.

see Extensions

Methods

Name Description
constructor(name: string): Extension Constructor for base Extension class  
onExecute(_args: string[]): Promise<void> Abstract Method called immediately following the call to onLoad when the Extension is first loaded, and also once for  
onLoad(_args: string[]): Promise<void> Method called when the Extension is first loaded.  
resolveResourceUrl(relativeUrl: string): string Returns a fully qualified resource URL which is needed when the extension is loaded from an external server  
setI18n(defaultNamespace?: string, options?: I18NOptions): void Can be used to set up a localization instance. Deprecated  

Properties

Name Type Description
_defaultNs Protected string Subclasses should override this with the default I18N namespace name.  
i18n Accessor ReadOnly I18N Property that retrieves the localization instance specific to the Extension.  
name string    

Defined in

Last Updated: 29 November, 2022