IModelApp Class

Global singleton that connects the user interface with the iModel.js services. There can be only one IModelApp active in a session. All members of IModelApp are static, and it serves as a singleton object for gaining access to session information.

Before any interactive operations may be performed by the @bentley/imodeljs-frontend package, IModelApp.startup must be called. Applications may customize the frontend behavior of iModel.js by supplying options to IModelApp.startup.

Methods

Name Description
constructor(): IModelApp Protected    
makeLogoCard(opts: { heading: string | HTMLElement, iconSrc?: string | HTMLImageElement, iconWidth?: number, notice?: string | HTMLElement }): HTMLTableRowElement Static Make a new Logo Card. Beta  
queryRenderCompatibility(): WebGLRenderCompatibilityInfo Static Obtain WebGL rendering compatibility information for the client system.  
shutdown(): Promise<void> Static Must be called before the application exits to release any held resources.  
startup(opts?: IModelAppOptions): Promise<void> Static This method must be called before any iModel.js frontend services are used.  
stopEventLoop(): void Static Strictly for tests.  
translateStatus(status: number): string Static Localize an error status from iModel.js Beta  

Properties

Name Type Description
accuSnap Accessor StaticReadOnly AccuSnap The AccuSnap for this session.  
animationInterval Accessor Static undefined | BeDuration Controls how frequently the application polls for changes that may require a new animation frame to be requested.  
applicationId Accessor StaticReadOnly string The Id of this application.  
applicationLogoCard Static undefined | () => HTMLTableRowElement    
applicationVersion Accessor StaticReadOnly string The version of this application.  
authorizationClient Static undefined | FrontendAuthorizationClient Provides authorization information for various frontend APIs  
extensionAdmin Accessor StaticReadOnly ExtensionAdmin The ExtensionAdmin for this session.  
i18n Accessor StaticReadOnly I18N The I18N for this session.  
iModelClient Accessor StaticReadOnly IModelClient    
notifications Accessor StaticReadOnly NotificationManager The NotificationManager for this session.  
renderSystem Accessor StaticReadOnly RenderSystem The RenderSystem for this session.  
securityOptions Accessor StaticReadOnly FrontendSecurityOptions The requested security options for the frontend.  
sessionId Static string A uniqueId for this session  
settings Accessor StaticReadOnly SettingsAdmin The SettingsAdmin for this session.  
tileAdmin Accessor StaticReadOnly TileAdmin The TileAdmin for this session.  
toolAdmin Accessor StaticReadOnly ToolAdmin The ToolAdmin for this session.  
tools StaticReadonly ToolRegistry The ToolRegistry for this session.  
uiAdmin Accessor StaticReadOnly UiAdmin The UiAdmin for this session.  
viewManager Accessor StaticReadOnly ViewManager The ViewManager for this session.  

Defined in

Last Updated: 29 November, 2022