reinstateTxn Method

Reinstate (redo) the most recently reversed transaction. Since at any time multiple transactions can be reversed, it may take multiple calls to this method to reinstate all reversed operations.

reinstateTxn(): Promise<IModelStatus>

note If there are any outstanding uncommitted changes, they are canceled before the Txn is reinstated.

see BriefcaseTxns.isRedoPossible to determine if any reinstatable operations exist.

see BriefcaseTxns.reverseSingleTxn or BriefcaseTxns.reverseAll to undo changes.

Returns - Promise<IModelStatus>

Success if a reversed transaction was reinstated, error status otherwise.

Defined in

Last Updated: 29 November, 2022