queryDefaultViewId Method

Query the Id of the default view associated with this iModel. Applications can choose to use this as the default view to which to open a viewport upon startup, or the initial selection within a view selection dialog, or similar purposes.

queryDefaultViewId(): Promise<string>

Returns - Promise<string>

the ID of the default view, or an invalid ID if no default view is defined.

Defined in

Last Updated: 29 November, 2022