Pixel.Selector Enumeration

Bit-mask by which callers of Viewport.readPixels specify which aspects are of interest. Aspects not specified will be omitted from the returned data.

Members

Name Value Description
None 0  
Feature 1 Select the Pixel.Selector.Feature which produced each pixel, as well as the PackedFeatureTable from which the feature originated.
GeometryAndDistance 4 Select the type and planarity of geometry which produced each pixel as well as the fraction of its distance between the near and far planes.
All 5 Select all aspects of each pixel.

Defined in

Last Updated: 29 November, 2022