UniformParams Interface

Parameters used to define a uniform variable for a ScreenSpaceEffectBuilder's shader program.

see ScreenSpaceEffectBuilder.addUniform to add a uniform variable to an effect shader.

Methods

Name Description
bind(uniform: Uniform, context: UniformContext): void A function that computes the value of the variable and binds it to the shader program each time the effect is rendered.  

Properties

Name Type Description
name string The name of the variable.  
type UniformType The data type of the uniform variable.  

Defined in

Last Updated: 29 November, 2022