TileUsageMarker Class

A marker associated with a Tile to track usage of that tile by any number of viewports. The marker tracks:

  • the set of Viewports in which the tile is in use for some purpose (displayed, preloaded, requested, selected for shadow map, etc); and
  • the most recent time at which any viewport declared its use of the tile. The marker is used to allow tiles to be discarded after they become disused by any viewport, via Tile.prune.

see Tile.usageMarker.

Methods

Name Description
constructor(): TileUsageMarker Constructs a usage marker with its timepoint set to the current time and its set of viewports empty.  
isExpired(expirationTime: BeTimePoint): boolean Returns true if this tile is currently in use by no viewports and its timestamp pre-dates expirationTime.  
mark(vp: Viewport, time: BeTimePoint): void Updates the timestamp to the specified time and marks the tile as being in use by the specified viewport.  

Defined in

Last Updated: 29 November, 2022