register MethodStatic

Register this Tool class with the ToolRegistry.

register(namespace?: I18NNamespace, i18n?: I18N): void

Parameter Type Description
namespace I18NNamespace optional namespace to supply to ToolRegistry.register. If undefined, use namespace from superclass.
i18n I18N optional internationalization services object (required only for externally hosted extensions). If undefined, use IModelApp.i18n.

Returns - void

Defined in

Last Updated: 29 November, 2022