run Method

Look up a tool by toolId and, if found, create an instance with the supplied arguments and run it.

run(toolId: string, ...args: any[]): boolean

Parameter Type Description
toolId string toolId of the immediate tool
...args any[] arguments to pass to the constructor, and to run.

Returns - boolean

true if the tool was found and successfully run.

Defined in

Last Updated: 29 November, 2022