ViewClipByRangeTool Class

A tool to define a clip volume for a view by specifying range corners

Extends

Methods

Name Description
constructor(_clipEventHandler?: ViewClipEventHandler): ViewClipByRangeTool    
getClipRange(range: Range3d, transform: Transform, ev: BeButtonEvent): boolean Protected    

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): boolean ViewClipTool Used to receive property changes from UI.
autoLockTarget(): void ViewClipTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void ViewClipTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> ViewClipTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void ViewClipTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with AccuSnap.isLocateEnabled and AccuSnap.isSnapEnabled.
decorateSuspended(_context: DecorateContext): void ViewClipTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void ViewClipTool Call to terminate dynamics mode.
exitTool(): void ViewClipTool  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> ViewClipTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void ViewClipTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps ViewClipTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string ViewClipTool Returns the prompt based on the tool's current state.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> ViewClipTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initLocateElements(enableLocate: boolean = true, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void ViewClipTool Helper method for tools that need to locate existing elements.
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean ViewClipTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onCleanup(): void ViewClipTool Invoked when the tool becomes no longer active, to perform additional cleanup logic
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> ViewClipTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void ViewClipTool Called to allow Tool to display dynamic elements.
onInstall(): boolean ViewClipTool Override to execute additional logic when tool is installed.
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> ViewClipTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> ViewClipTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> ViewClipTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> ViewClipTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> ViewClipTool Invoked when the button is released after onMouseStartDrag.
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> ViewClipTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> ViewClipTool Invoked when the mouse wheel moves.
onRedoPreviousStep(): Promise<boolean> ViewClipTool Called to reinstate to a previous tool state (ex.
onReinitialize(): void ViewClipTool Called to reset tool to initial state.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> ViewClipTool Invoked when the reset button is pressed.
onSelectedViewportChanged(_previous: undefined | Viewport, current: undefined | Viewport): void ViewClipTool Called when active view changes.
onSuspend(): void ViewClipTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(_ev: BeTouchEvent): Promise<void> ViewClipTool Called when a touch point is interrupted in some way and needs to be dropped from the list of target touches.
onTouchComplete(_ev: BeTouchEvent): Promise<void> ViewClipTool Called when the last touch point is removed from the surface completing the current gesture.
onTouchEnd(_ev: BeTouchEvent): Promise<void> ViewClipTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(_ev: BeTouchEvent): Promise<void> ViewClipTool Called when a touch point moves along the surface.
onTouchMoveStart(_ev: BeTouchEvent, _startEv: BeTouchEvent): Promise<EventHandled> ViewClipTool Called after at least one touch point has moved for an appreciable time and distance along the surface to not be considered a tap.
onTouchStart(_ev: BeTouchEvent): Promise<void> ViewClipTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> ViewClipTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
parseAndRun(..._args: string[]): boolean ViewClipTool Run this instance of a tool using a series of string arguments.
reloadToolSettingsProperties(): void ViewClipTool Called by tool to inform UI to reload ToolSettings with new set of properties.
run(..._args: any[]): boolean ViewClipTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> ViewClipTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
supplyToolSettingsProperties(): undefined | DialogItem[] ViewClipTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void ViewClipTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean ViewClipTool Called to support operations on pickable decorations, like snapping.
areClipsEqual(clipA: ClipVector, clipB: ClipVector): boolean Static ViewClipTool  
doClipClear(viewport: Viewport): boolean Static ViewClipTool  
doClipToConvexClipPlaneSet(viewport: Viewport, planes: ConvexClipPlaneSet): boolean Static ViewClipTool  
doClipToPlane(viewport: Viewport, origin: Point3d, normal: Vector3d, clearExistingPlanes: boolean): boolean Static ViewClipTool  
doClipToRange(viewport: Viewport, range: Range3d, transform?: Transform): boolean Static ViewClipTool  
doClipToShape(viewport: Viewport, xyPoints: Point3d[], transform?: Transform, zLow?: number, zHigh?: number): boolean Static ViewClipTool  
drawClipPlanesLoops(context: DecorateContext, loops: GeometryQuery[], color: ColorDef, weight: number, dashed?: boolean, fill?: ColorDef, id?: string): void Static ViewClipTool  
drawClipShape(context: DecorateContext, shape: ClipShape, extents: Range1d, color: ColorDef, weight: number, id?: string): void Static ViewClipTool  
enableClipVolume(viewport: Viewport): boolean Static ViewClipTool  
hasClip(viewport: Viewport): boolean Static ViewClipTool  
register(namespace?: I18NNamespace, i18n?: I18N): void Static ViewClipTool Register this Tool class with the ToolRegistry.
setViewClip(viewport: Viewport, clip?: ClipVector): boolean Static ViewClipTool  

Properties

Name Type Description
iconSpec Static string The icon for this Tool.  
toolId Static string The unique string that identifies this tool.  

Inherited properties

Name Type Inherited from Description
_clipEventHandler Protected undefined | ViewClipEventHandler ViewClipTool  
description Accessor ReadOnly string ViewClipTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string ViewClipTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
ViewClipTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string ViewClipTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string ViewClipTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string ViewClipTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
ViewClipTool.keyin is returned.
hidden Static boolean ViewClipTool If true, this Tool will not appear in the list from ToolRegistry.getToolList.
i18n Static I18N ViewClipTool The internationalization services instance used to translate strings from the namespace.
iconSpec Accessor ReadOnly string ViewClipTool Get the iconSpec from this Tool's class.
iModel Accessor ReadOnly IModelConnection ViewClipTool Get the iModel on which this tool operates.
isControlDown Accessor ReadOnly boolean ViewClipTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor ReadOnly boolean ViewClipTool Call to find out if dynamics are currently active.
keyin Accessor ReadOnly string ViewClipTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string ViewClipTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
maxArgs Accessor StaticReadOnly undefined | number ViewClipTool The maximum number of arguments allowed by ViewClipTool.parseAndRun, or undefined if there is no maximum.
If subclasses override ViewClipTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor StaticReadOnly number ViewClipTool The minimum number of arguments allowed by ViewClipTool.parseAndRun. If subclasses override ViewClipTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static I18NNamespace ViewClipTool The I18NNamespace that provides localized strings for this Tool.
receivedDownEvent boolean ViewClipTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked boolean ViewClipTool  
targetModelId Accessor undefined | string ViewClipTool  
targetView undefined | Viewport ViewClipTool The viewport within which the tool operates.
toolId Accessor ReadOnly string ViewClipTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.

Defined in

Last Updated: 29 November, 2022