ViewCreator3dOptions Interface

Options for creating a ViewState3d via ViewCreator3d.

Properties

Name Type Description
cameraOn undefined | boolean Turn Camera on when generating the view.  
skyboxOn undefined | boolean Turn SkyBox on when generating the view.  
standardViewId undefined | StandardViewId StandardViewId for the view state.  
useSeedView undefined | boolean Merge in props from the seed view (default spatial view) of the iModel.  
vpAspect undefined | number Aspect ratio of Viewport.  

Defined in

Last Updated: 29 November, 2022