RedlineTool Class

Base class for tools that place new Markup elements

Extends

Extended by

Methods

Name Description
constructor(..._args: any[]): RedlineTool    
clearDynamicsMarkup(_isDynamics: boolean): void Protected    
createMarkup(_svgMarkup: G, _ev: BeButtonEvent, _isDynamics: boolean): void Protected    
isComplete(_ev: BeButtonEvent): boolean Protected    
onAdded(el: Element): void Protected    
onCleanup(): void Invoked when the tool becomes no longer active, to perform additional cleanup logic  
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> Invoked when the data button is pressed.  
onMouseMotion(ev: BeButtonEvent): Promise<void> Invoked when the cursor is moving  
onReinitialize(): void Called to reset tool to initial state.  
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> Invoked when the reset button is released.  
onRestartTool(): void    
onUndoPreviousStep(): Promise<boolean> Called to reverse to a previous tool state (ex.  
provideToolAssistance(mainInstrKey: string, singlePoint: boolean = false): void Protected    
setupAndPromptForNextAction(): void Protected    

Inherited methods

Name Inherited from Description
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): boolean MarkupTool Used to receive property changes from UI.
autoLockTarget(): void MarkupTool Called on data button down event to lock the tool to its current target model.
beginDynamics(): void MarkupTool Call to initialize dynamics mode.
bumpToolSetting(_settingIndex?: number): Promise<boolean> MarkupTool Used to "bump" the value of a tool setting.
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void MarkupTool Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled.
decorate(_context: DecorateContext): void MarkupTool Called to allow an active tool to display non-element decorations in overlay mode.
decorateSuspended(_context: DecorateContext): void MarkupTool Called to allow a suspended tool to display non-element decorations in overlay mode.
endDynamics(): void MarkupTool Call to terminate dynamics mode.
exitTool(): void MarkupTool  
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> MarkupTool Invoked to allow tools to filter which elements can be located.
getCurrentButtonEvent(ev: BeButtonEvent): void MarkupTool Fill the supplied button event from the current cursor location.
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps MarkupTool Called to allow snapping to pickable decoration geometry.
getPrompt(): string MarkupTool Returns the prompt based on the tool's current state.
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> MarkupTool Invoked before the locate tooltip is displayed to retrieve the information about the located element.
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void MarkupTool Helper method for tools that need to locate existing elements.
isCompatibleViewport(vp: undefined | Viewport, isSelectedViewChange: boolean): boolean MarkupTool  
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean MarkupTool Checks that the adjusted point from the supplied button event is within the project extents for spatial views.
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> MarkupTool Invoked when the data button is released.
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void MarkupTool Called to allow Tool to display dynamic elements.
onInstall(): boolean MarkupTool  
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> MarkupTool Called when any key is pressed or released.
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> MarkupTool Invoked when the middle mouse button is pressed.
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> MarkupTool Invoked when the middle mouse button is released.
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> MarkupTool Called when Control, Shift, or Alt modifier keys are pressed or released.
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> MarkupTool Invoked when the button is released after onMouseStartDrag.
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> MarkupTool Invoked when the cursor begins moving while a button is depressed.
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> MarkupTool Invoked when the mouse wheel moves.
onPostInstall(): void MarkupTool  
onRedoPreviousStep(): Promise<boolean> MarkupTool Called to reinstate to a previous tool state (ex.
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> MarkupTool Invoked when the reset button is pressed.
onSelectedViewportChanged(_previous: undefined | Viewport, current: undefined | Viewport): void MarkupTool Called when active view changes.
onSuspend(): void MarkupTool Notification of a ViewTool or InputCollector starting and this tool is being suspended.
onTouchCancel(ev: BeTouchEvent): Promise<void> MarkupTool  
onTouchComplete(ev: BeTouchEvent): Promise<void> MarkupTool  
onTouchEnd(_ev: BeTouchEvent): Promise<void> MarkupTool Called when user removes a touch point by lifting a finger or stylus from the surface.
onTouchMove(ev: BeTouchEvent): Promise<void> MarkupTool  
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> MarkupTool  
onTouchStart(_ev: BeTouchEvent): Promise<void> MarkupTool Called when user adds a touch point by placing a finger or stylus on the surface.
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> MarkupTool Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving.
onUnsuspend(): void MarkupTool  
outputMarkupPrompt(msg: string): void Protected MarkupTool  
parseAndRun(..._args: string[]): boolean MarkupTool Run this instance of a tool using a series of string arguments.
pickElement(pt: Readonly<WritableXAndY>): undefined | Element MarkupTool Find the topmost MarkupElement at the specified point in the markup view.
redoPreviousStep(): Promise<boolean> MarkupTool  
reloadToolSettingsProperties(): void MarkupTool Called by tool to inform UI to reload ToolSettings with new set of properties.
requireWriteableTarget(): boolean MarkupTool  
run(..._args: any[]): boolean MarkupTool Establish this tool as the active PrimitiveTool.
saveChanges(): Promise<void> MarkupTool If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string.
setCurrentStyle(element: Element, canBeFilled: boolean): void Protected MarkupTool  
setCurrentTextStyle(element: Element): void Protected MarkupTool  
showPrompt(): void Protected MarkupTool  
supplyToolSettingsProperties(): undefined | DialogItem[] MarkupTool Used to supply list of properties that can be used to generate ToolSettings.
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void MarkupTool Called by tool to synchronize the UI with property changes made by tool.
testDecorationHit(_id: string): boolean MarkupTool Called to support operations on pickable decorations, like snapping.
undoPreviousStep(): Promise<boolean> MarkupTool  
register(namespace?: I18NNamespace, i18n?: I18N): void Static MarkupTool Register this Tool class with the ToolRegistry.

Properties

Name Type Description
_minPoints Protected number    
_nRequiredPoints Protected number    
_points ProtectedReadonly Point3d[]    

Inherited properties

Name Type Inherited from Description
description Accessor ReadOnly string MarkupTool Get the localized description string from this Tool's class
description Accessor StaticReadOnly string MarkupTool Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
MarkupTool.flyover is returned.
englishKeyin Accessor StaticReadOnly string MarkupTool Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
flyover Accessor ReadOnly string MarkupTool Get the localized flyover string from this Tool's class
flyover Accessor StaticReadOnly string MarkupTool Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from
its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace,
MarkupTool.keyin is returned.
hidden Static boolean MarkupTool If true, this Tool will not appear in the list from getToolList.
i18n Static I18N MarkupTool The internationalization services instance used to translate strings from the namespace.
iconSpec Accessor ReadOnly string MarkupTool Get the iconSpec from this Tool's class.
iconSpec Static string MarkupTool The icon for this Tool.
iModel Accessor ReadOnly IModelConnection MarkupTool Get the iModel on which this tool operates.
isControlDown Accessor ReadOnly boolean MarkupTool Convenience method to check whether control key is currently down without needing a button event.
isDynamicsStarted Accessor ReadOnly boolean MarkupTool Call to find out if dynamics are currently active.
keyin Accessor ReadOnly string MarkupTool Get the localized keyin string from this Tool's class
keyin Accessor StaticReadOnly string MarkupTool Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from
its registered Namespace (e.g. "en/MyApp.json").
markup Markup MarkupTool  
maxArgs Accessor StaticReadOnly undefined | number MarkupTool The maximum number of arguments allowed by MarkupTool.parseAndRun, or undefined if there is no maximum.
If subclasses override MarkupTool.parseAndRun, they should also override this method to indicate the maximum
number of arguments their implementation expects.
minArgs Accessor StaticReadOnly number MarkupTool The minimum number of arguments allowed by MarkupTool.parseAndRun. If subclasses override MarkupTool.parseAndRun, they should also
override this method to indicate the minimum number of arguments their implementation expects. UI controls can use
this information to ensure the tool has enough information to execute.
namespace Static I18NNamespace MarkupTool The I18NNamespace that provides localized strings for this Tool.
receivedDownEvent boolean MarkupTool Used to avoid sending tools up events for which they did not receive the down event.
targetIsLocked boolean MarkupTool  
targetModelId Accessor undefined | string MarkupTool  
targetView undefined | Viewport MarkupTool The viewport within which the tool operates.
toolId Accessor ReadOnly string MarkupTool Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize
the keyin, description, etc. from the current locale.
toolId Static string MarkupTool The unique string that identifies this tool.
toolKey Static string MarkupTool  

Defined in

Last Updated: 29 November, 2022