ChunkedQueryContext Class

Beta  

Context for holding chunked query data.

Methods

Name Description
constructor(): ChunkedQueryContext    
handleIteration(queryOptions: RequestQueryOptions): void Prepares for next chunked query iteration.  
create(queryOptions: RequestQueryOptions): undefined | ChunkedQueryContext Static Creates chunked query context if it is applicable for provided query.  

Properties

Name Type Description
instancesLeft Accessor ReadOnly undefined | number Count of instances that are left to query.  
isQueryFinished Accessor ReadOnly boolean Returns true if chunked query finished executing.  
skipToken Accessor string Current query skip token.  

Defined in

Last Updated: 29 November, 2022