DescriptorJSON Interface

Serialized Descriptor JSON representation.

Properties

Name Type Description
categories undefined | CategoryDescriptionJSON[]    
connectionId string    
contentFlags number    
contentOptions any    
displayType string    
fields FieldJSON<ClassInfoJSON>[]    
filterExpression undefined | string    
inputKeysHash string    
selectClasses SelectClassInfoJSON<ClassInfoJSON>[]    
selectionInfo undefined | SelectionInfo    
sortDirection undefined | SortDirection    
sortingFieldName undefined | string    

Defined in

Last Updated: 29 November, 2022