PresentationError Class

An error type thrown by Presentation APIs.

Extends

  • BentleyError

Methods

Name Description
constructor(errorNumber: PresentationStatus, message?: string, log?: LogFunction, getMetaData?: GetMetaDataFunction): PresentationError Creates an instance of Error.  
_initName(): string Protected Returns the name of each error status.  

Inherited methods

Name Inherited from Description
BentleyError Return the meta data associated with this BentleyError.

Inherited properties

Name Type Inherited from Description
errorNumber number BentleyError  
boolean BentleyError Returns true if this BentleyError includes (optional) meta data.

Defined in

Last Updated: 29 November, 2022