ChildNodeSpecificationBase Interface

Base interface for all ChildNodeSpecification implementations. Not meant to be used directly, see ChildNodeSpecification.

Properties

Name Type Description
doNotSort undefined | boolean Set this flag to true to suppress default sorting of ECInstances returned by this specification.  
hasChildren "Always" | "Never" | "Unknown" This tells the rules engine that nodes produced using this  
hideExpression undefined | string An ECExpression which  
hideIfNoChildren undefined | boolean Hide nodes if they don't have children.  
hideNodesInHierarchy undefined | boolean Hide instance nodes provided by this specification and directly show nodes of its children.  
nestedRules undefined | ChildNodeRule[] Nested rule specifications.  
priority undefined | number Defines the order in which specifications are evaluated and executed.  
relatedInstances undefined | RelatedInstanceSpecification[] Specifications of related instances that can be used in nodes' creation.  
specType ChildNodeSpecificationTypes Used for serializing to JSON.  
suppressSimilarAncestorsCheck undefined | boolean Suppress similar ancestor nodes' checking when creating nodes based on this specification. Beta  

Defined in

Last Updated: 29 November, 2022