PropertyCategorySpecification Interface

Specification to define a custom property category.

see More details

Properties

Name Type Description
autoExpand undefined | boolean Should this category be auto-expanded.  
description undefined | string Optional extensive description of the category.  
id string Category identifier which has to be unique at the scope of it's definition.  
label string Display label of the category.  
parentId string | NoCategoryIdentifier | CategoryIdentifier Identifier of a parent category.  
priority undefined | number Priority of the category.  
renderer undefined | CustomRendererSpecification Custom category renderer specification.  

Defined in

Last Updated: 29 November, 2022