PropertyOverrides Interface

A container structure for possible property overrides

Properties

Name Type Description
categoryId string | CategoryIdentifier Identifier of a category that should be used for the property.  
doNotHideOtherPropertiesOnDisplayOverride undefined | boolean Flag to control behavior of isDisplayed override when it's set to true.  
editor undefined | PropertyEditorSpecification Custom property editor specification.  
isDisplayed undefined | boolean Display override.  
labelOverride undefined | string Label override.  
overridesPriority undefined | number Priority of the specified overrides.  
renderer undefined | CustomRendererSpecification Custom property renderer specification.  

Defined in

Last Updated: 29 November, 2022