RuleBase Interface

Base interface for all Rule implementations. Not meant to be used directly, see Rule.

Properties

Name Type Description
onlyIfNotHandled undefined | boolean Should this rule should be ignored if there is already an existing  
priority undefined | number Defines the order in which presentation rules will be evaluated and executed.  
requiredSchemas undefined | RequiredSchemaSpecification[] Schema requirements for this rule. Beta  
ruleType RuleTypes Used for serializing to JSON.  

Defined in

Last Updated: 29 November, 2022