DEPRECATED_controlledTreeWithFilteringSupport Function

A HOC component that adds filtering functionality to the supplied controlled tree component.

DEPRECATED_controlledTreeWithFilteringSupport<P extends ControlledTreeWithVisibleNodesProps<P>>(TreeComponent: FC<P>): FC<Omit<CombinedProps, "visibleNodes">>

note It's required for the tree to use PresentationTreeDataProvider and wrap supplied tree component in DEPRECATED_controlledTreeWithVisibleNodes HOC

Parameter Type Description
TreeComponent FC<P>  

Returns - FC<Omit<CombinedProps, "visibleNodes">>

Defined in

Last Updated: 29 November, 2022