TreeWithFilteringSupportProps Interface

Deprecated  Use useControlledTreeFiltering instead. Will be removed in iModel.js 3.0

Props that are injected to the TreeWithFilteringSupport HOC component.

Methods

Name Description
onFilterApplied(filter: string, filteredProvider: IPresentationTreeDataProvider): void Optional Called when filter is applied.  
onMatchesCounted(count: number): void Optional Called when FilteredDataProvider counts the number of matches  

Properties

Name Type Description
activeMatchIndex undefined | number Index of the active match  
dataProvider IPresentationTreeDataProvider The data provider used by the tree.  
filter undefined | string The text to search for  

Defined in

Last Updated: 29 November, 2022