TreeWithUnifiedSelectionProps Interface

Deprecated  Use useControlledTreeFiltering instead. Will be removed in iModel.js 3.0

Props that are injected to the TreeWithUnifiedSelection HOC component.

Methods

Name Description
onNodesDeselected(items: TreeNodeItem[]): boolean Optional Called when nodes are deselected.  
onNodesSelected(items: TreeNodeItem[], replace: boolean): boolean Optional Called when nodes are selected.  

Properties

Name Type Description
dataProvider IPresentationTreeDataProvider The data provider used by the tree.  

Defined in

Last Updated: 29 November, 2022