PresentationManager Class

Frontend Presentation manager which basically just forwards all calls to the backend implementation.

Implements

Methods

Name Description
compareHierarchies(props: HierarchyCompareOptions<IModelConnection, NodeKey, RulesetVariable>): Promise<PartialHierarchyModification[]> Compare two hierarchies.  
dispose(): void    
getContent(requestOptions: Paged<ExtendedContentRequestOptions<IModelConnection, Descriptor, KeySet, RulesetVariable>>): Promise<undefined | Content>    
getContent(requestOptions: Paged<ContentRequestOptions<IModelConnection, RulesetVariable>>, descriptorOrOverrides: Descriptor | DescriptorOverrides, keys: KeySet): Promise<undefined | Content> Retrieves the content based on the supplied content descriptor override. Deprecated  
getContentAndSize(requestOptions: Paged<ExtendedContentRequestOptions<IModelConnection, Descriptor, KeySet, RulesetVariable>>): Promise<undefined | { content: Content, size: number }>    
getContentAndSize(requestOptions: Paged<ContentRequestOptions<IModelConnection, RulesetVariable>>, descriptorOrOverrides: Descriptor | DescriptorOverrides, keys: KeySet): Promise<undefined | { content: Content, size: number }> Retrieves the content and content set size based on the supplied content descriptor override. Deprecated  
getContentDescriptor(requestOptions: ContentDescriptorRequestOptions<IModelConnection, KeySet, RulesetVariable>): Promise<undefined | Descriptor>    
getContentDescriptor(requestOptions: ContentRequestOptions<IModelConnection, RulesetVariable>, displayType: string, keys: KeySet, selection: undefined | SelectionInfo): Promise<undefined | Descriptor> Retrieves the content descriptor which describes the content and can be used to customize it. Deprecated  
getContentSetSize(requestOptions: ExtendedContentRequestOptions<IModelConnection, Descriptor, KeySet, RulesetVariable>): Promise<number>    
getContentSetSize(requestOptions: ContentRequestOptions<IModelConnection, RulesetVariable>, descriptorOrOverrides: Descriptor | DescriptorOverrides, keys: KeySet): Promise<number> Retrieves content set size based on the supplied content descriptor override. Deprecated  
getDisplayLabelDefinition(requestOptions: DisplayLabelRequestOptions<IModelConnection, InstanceKey>): Promise<LabelDefinition>    
getDisplayLabelDefinition(requestOptions: LabelRequestOptions<IModelConnection>, key: InstanceKey): Promise<LabelDefinition> Retrieves display label definition of specific item Deprecated  
getDisplayLabelDefinitions(requestOptions: DisplayLabelsRequestOptions<IModelConnection, InstanceKey>): Promise<LabelDefinition[]>    
getDisplayLabelDefinitions(requestOptions: LabelRequestOptions<IModelConnection>, keys: InstanceKey[]): Promise<LabelDefinition[]> Retrieves display label definition of specific items Deprecated  
getDistinctValues(requestOptions: ContentRequestOptions<IModelConnection, RulesetVariable>, descriptorOrOverrides: Descriptor | DescriptorOverrides, keys: KeySet, fieldName: string, maximumValueCount: number = 0): Promise<string[]> Retrieves distinct values of specific field from the content based on the supplied content descriptor override. Deprecated  
getElementProperties(requestOptions: ElementPropertiesRequestOptions<IModelConnection>): Promise<undefined | ElementProperties> Retrieves property data in a simplified format for a single element specified by ID. Beta  
getFilteredNodePaths(requestOptions: ExtendedHierarchyRequestOptions<IModelConnection, never, RulesetVariable>, filterText: string): Promise<NodePathElement[]> Retrieves paths from root nodes to nodes containing filter text in their label.  
getNodePaths(requestOptions: ExtendedHierarchyRequestOptions<IModelConnection, never, RulesetVariable>, paths: InstanceKey[][], markedIndex: number): Promise<NodePathElement[]> Retrieves paths from root nodes to children nodes according to specified keys.  
getNodes(requestOptions: Paged<ExtendedHierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable>>): Promise<Node[]> Retrieves nodes  
getNodes(requestOptions: Paged<HierarchyRequestOptions<IModelConnection, RulesetVariable>>, parentKey: undefined | NodeKey): Promise<Node[]> Retrieves nodes Deprecated  
getNodesAndCount(requestOptions: Paged<ExtendedHierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable>>): Promise<{ count: number, nodes: Node[] }> Retrieves total nodes count and a single page of nodes.  
getNodesAndCount(requestOptions: Paged<HierarchyRequestOptions<IModelConnection, RulesetVariable>>, parentKey: undefined | NodeKey): Promise<{ count: number, nodes: Node[] }> Retrieves total nodes count and a single page of nodes. Deprecated  
getNodesCount(requestOptions: ExtendedHierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable>): Promise<number> Retrieves nodes count.  
getNodesCount(requestOptions: HierarchyRequestOptions<IModelConnection, RulesetVariable>, parentKey: undefined | NodeKey): Promise<number> Retrieves nodes count. Deprecated  
getPagedDistinctValues(requestOptions: DistinctValuesRequestOptions<IModelConnection, Descriptor, KeySet, RulesetVariable>): Promise<PagedResponse<DisplayValueGroup>> Retrieves distinct values of specific field from the content based on the supplied content descriptor override.  
rulesets(): RulesetManager Get rulesets manager  
vars(rulesetId: string): RulesetVariablesManager Get ruleset variables manager for specific ruleset  
create(props?: PresentationManagerProps): PresentationManager Static Create a new PresentationManager instance  

Properties

Name Type Description
activeLocale undefined | string Get / set active locale used for localizing presentation data  
activeUnitSystem undefined | PresentationUnitSystem Get / set active unit system used to format property values with units  

Defined in

Last Updated: 29 November, 2022