SettingsStatus Enumeration

Beta  

Possible values for SettingsResults.status

Members

Name Value Description
Success 0 The specified setting was successfully saved, deleted, or retrieved.
SETTINGS_ERROR_BASE 110592  
AuthorizationError 110593 Access to the specified setting was blocked.
UrlError 110594 The Url for the setting is not properly formed. Check the characters in the setting name.
ProjectInvalid 110595 An invalid projectId was specified.
IModelInvalid 110596 An invalid iModelId was specified.
SettingNotFound 110597 The setting specified for deletion or retrieval does not exist.
ServerError 110598 The settings server malfunctioned.
UnknownError 110600 An unexpected error occurred.

Defined in

Last Updated: 29 November, 2022