UiItemsProvider Interface

Describes interface of objects that want to provide UI component to the running IModelApp.

Methods

Name Description
onBackstageItemArbiterChange(item: BackstageItem, action: UiItemsApplicationAction): void Optional Called if the application changed the Backstage item  
onStatusBarItemArbiterChange(item: CommonStatusBarItem, action: UiItemsApplicationAction): void Optional Called if the application changed the StatusBar item  
onToolbarButtonItemArbiterChange(item: CommonToolbarItem, action: UiItemsApplicationAction): void Optional Called if the application changed the Toolbar button item  
onWidgetArbiterChange(widget: AbstractWidgetProps, action: UiItemsApplicationAction): void Optional Called if the application changed the Widget  
provideBackstageItems(): BackstageItem[] Optional UiItemsManager calls following method to augment backstage items.  
provideStatusBarItems(stageId: string, stageUsage: string): CommonStatusBarItem[] Optional UiItemsManager calls following method to augment base statusbar for stages that allow it.  
provideToolbarButtonItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation): CommonToolbarItem[] Optional UiItemsManager calls following method to get items to populate specific toolbars  
provideWidgets(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection, zoneLocation?: AbstractZoneLocation): undefined Optional UiItemsManager calls following method to augment Widget lists.  

Properties

Name Type Description
id Readonly string id of provider  

Defined in

Last Updated: 29 November, 2022