ColorPickerPopupProps Interface

Beta  

Properties for the ColorPickerPopup React component

Extends

Properties

Name Type Description
captureClicks undefined | boolean If true, don't propagate clicks out of the ColorPicker  
colorDefs undefined | ColorDef[] Preset colors.  
disabled undefined | boolean Disabled or not  
initialColor ColorDef Current color  
onClose undefined | (colorValue: ColorDef) => void    
onColorChange undefined | (newColor: ColorDef) => void    
popupPosition undefined | RelativePosition popup position.  
readonly undefined | boolean Readonly or not, color displayed on button but button will not trigger pop-up  
ref undefined | Ref<HTMLButtonElement> Provides ability to return reference to HTMLButtonElement  
showCaret undefined | boolean If true show up/down caret next to color  

Defined in

Last Updated: 29 November, 2022