DEPRECATED_FilteringInputProps Interface

Deprecated  

FilteringInput React Component properties

Extends

Methods

Name Description
onFilterCancel(): void Filtering is canceled while still in progress  
onFilterClear(): void Filtering is cleared after everything's loaded  
onFilterStart(searchText: string): void Filtering should start  

Properties

Name Type Description
autoFocus undefined | boolean Specify that the element should automatically get focus  
filteringInProgress boolean Tells the component if parent component is still handling the filtering. Deprecated  
resultSelectorProps undefined | ResultSelectorProps ResultSelector React Component properties  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022