NEW_FilteringInputProps Interface

FilteringInput React Component properties

Extends

Methods

Name Description
onFilterCancel(): void Filtering is canceled while still in progress  
onFilterClear(): void Filtering is cleared after everything's loaded  
onFilterStart(searchText: string): void Filtering should start  

Properties

Name Type Description
autoFocus undefined | boolean Specify that the element should automatically get focus  
resultSelectorProps undefined | ResultSelectorProps ResultSelector React Component properties.  
status FilteringInputStatus Tells the component what is the status of filtering. Beta  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022