QuantityProps Interface

Beta  

Props for QuantityInput control

Extends

Methods

Name Description
onQuantityChange(newQuantityValue: number): void Function to call in the quantity value is changed.  

Properties

Name Type Description
initialValue number Initial magnitude in 'persistence' units.  
quantityType QuantityTypeArg Type of quantity being input.  
readonly undefined | boolean Set to true if value is for display only  
ref undefined | Ref<HTMLInputElement> Provides ability to return reference to HTMLInputElement  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022