PropertyValueRendererContext Interface
Additional parameters to the renderer
Methods
Name | Description | |
---|---|---|
onDialogOpen(dialogState: PropertyDialogState): void Optional | Callback to request for Dialog to be opened. | |
onExpansionToggled(): void Optional | Called when property value expansion or collapse is requested. | |
onHeightChanged(newHeight: number): void Optional | Called when property value element height changes. | |
onPopupHide(): void Optional | Callback to request for a Popup to be hidden. | |
onPopupShow(popupState: PropertyPopupState): void Optional | Callback to request for a Popup to be shown. | |
textHighlighter(text: string): ReactNode Optional | Callback to highlight text |
Properties
Name | Type | Description | |
---|---|---|---|
containerType | undefined | string | Type of container that holds the property | |
decoratedTextElement | undefined | ReactNode | Text with custom style applied to it | |
defaultValue | undefined | ReactNode | Default value to show if value rendering is asynchronous | |
isExpanded | undefined | boolean | Whether property value is expanded. | |
orientation | undefined | Orientation | Orientation of property/container | |
style | undefined | CSSProperties | Style that should be applied to the rendered element |
Defined in
Last Updated: 11 June, 2024