PropertyEditorProps Interface

Beta  

Properties for a property editor component

Extends

Methods

Name Description
onBlur(event: FocusEvent<Element>): void Optional Handler for blur  
onCancel(): void Optional Handler for cancel  
onCommit(args: PropertyUpdatedArgs): void Optional Handler for commit  

Properties

Name Type Description
propertyRecord undefined | PropertyRecord The property being updated.  
setFocus undefined | boolean Indicates whether the Property Editor should set focus  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022