FilterDescriptorCollectionBase<TDescriptor extends FilterDescriptor> Class

Collection of filter descriptors.

Extended by

Methods

Name Description
constructor<TDescriptor extends FilterDescriptor>(): FilterDescriptorCollectionBase<TDescriptor>    
add(item: TDescriptor): void Adds an FilterDescriptor to the collection.  
clear(): void Clears the collection.  
remove(item: TDescriptor): boolean Removes a particular FilterDescriptor from the collection.  

Properties

Name Type Description
count Accessor ReadOnly number Gets the count of items in the collection.  
descriptors Accessor ReadOnly TDescriptor[]    
isActive Accessor ReadOnly boolean Determines if the collection is active.  

Defined in

Last Updated: 29 November, 2022