TableCellContentProps Interface

Properties of the TableCellContent React component

Extends

Methods

Name Description
onDialogOpen(state: PropertyDialogState): void Optional Callback to DialogOpen event  

Properties

Name Type Description
cellItem CellItem Props for the item that will be rendered  
height undefined | number Height of the component  
isSelected boolean Indicates, whether container cell is selected or not  
propertyValueRendererManager PropertyValueRendererManager Property value renderer manager  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022