ImageCheckBoxProps Interface

Properties for the ImageCheckBox component

Extends

Methods

Name Description
onClick(checked: boolean): any Optional Function called when item is clicked.  

Properties

Name Type Description
border undefined | boolean If true, draw a border around the image checkbox  
checked undefined | boolean Determine if the item is checked or not  
disabled undefined | boolean Determine if the item is disabled or not  
imageOff ReactNode Image for the "unchecked" (default) state  
imageOn ReactNode Image for the "checked" state  
inputClassName undefined | string Custom CSS class name for the checkbox input element  
inputRef undefined | Ref<HTMLInputElement> Provides ability to return reference to HTMLInputElement  
inputStyle undefined | CSSProperties Custom CSS Style for the checkbox input element  
tooltip undefined | string Tooltip to be displayed when mouse is hovered over the checkbox  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022