PopupContextMenuProps Interface

Beta  

Properties for PopupContextMenu component

Extends

Methods

Name Description
onClose(): void Optional Function called when the popup is closed  
onEnter(): void Optional Function called when the popup is closed on Enter  
onEsc(event: KeyboardEvent<Element>): void Optional when Escape button is pressed  
onOpen(): void Optional Function called when the popup is opened  
onOutsideClick(e: MouseEvent): void Optional Function called when user clicks outside the popup  
onSelect(event: undefined | MouseEvent<Element, MouseEvent>): void Optional When list item or submenu is selected  

Properties

Name Type Description
animate undefined | boolean Indicates whether to use animation for open/close (defaults to true)  
ariaLabel undefined | string accessibility label  
autoflip undefined | boolean Whether menu flips directions based on screen edge.  
children undefined | ReactNode ContextMenu items  
edgeLimit undefined | boolean Whether menu hugs screen edge when autoflip is off.  
hotkeySelect undefined | boolean Whether Hotkey press selects item, or just highlights item.  
isOpen boolean Indicates whether the popup is shown or not (defaults to false)  
left undefined | number Left position (absolute positioning - defaults to 0)  
offset undefined | number Offset from the parent (defaults to 4)  
position undefined | RelativePosition Direction (relative to the target) to which the popup is expanded (defaults to Bottom)  
selectedIndex undefined | number starting menu item selected index Default: -1  
target | HTMLElement Target element to position popup  
top undefined | number Top position (absolute positioning - defaults to 0)  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022