IconInputProps Interface

Properties for the IconInput component

Extends

Inherited methods

Name Inherited from Description
nativeKeyHandler(e: KeyboardEvent): void Optional InputProps  

Properties

Name Type Description
containerClassName undefined | string CSS class name for the IconInput component container div  
icon ReactNode Icon displayed to the left of the Input field within the IconInput component  
ref undefined | Ref<HTMLInputElement> Provides ability to return reference to HTMLInputElement  

Inherited properties

Name Type Inherited from Description
setFocus undefined | boolean InputProps Indicates whether to set focus to the input element

Defined in

Last Updated: 29 November, 2022