LabeledTextareaProps Interface

Properties for LabeledTextarea component

Extends

Inherited properties

Name Type Inherited from Description
inputClassName undefined | string LabeledComponentProps Custom CSS class name for the checkbox input element
inputStyle undefined | CSSProperties LabeledComponentProps Custom CSS Style for the checkbox input element
label undefined | string LabeledComponentProps Text that will be shown next to or above the input.
labelClassName undefined | string LabeledComponentProps Custom CSS class name for the label
labelStyle undefined | CSSProperties LabeledComponentProps Custom CSS Style for the label
message undefined | string MessagedComponentProps Optional text shown below the input.
messageClassName undefined | string MessagedComponentProps Custom CSS class name for the message
messageStyle undefined | CSSProperties MessagedComponentProps Custom CSS Style for the message
ref undefined | Ref<HTMLTextAreaElement> TextareaProps Provides ability to return reference to HTMLInputElement
rows undefined | number TextareaProps Number of textarea rows.
setFocus undefined | boolean TextareaProps Indicates whether to set focus to the textarea element
status undefined | InputStatus LabeledComponentProps Input status like: "Success", "Warning" or "Error"

Defined in

Last Updated: 29 November, 2022