RadialMenu Class

Beta  

A context menu arranged in a radial layout.

Extends

Methods

Name Description
constructor(props: RadialMenuProps): RadialMenu    
componentDidMount(): void    
componentDidUpdate(prevProps: RadialMenuProps): void    
componentWillUnmount(): void    
render(): Element    
select(): void Manually call onSelect of highlighted button.  

Properties

Name Type Description
defaultProps Static Partial<RadialMenuProps>    

Defined in

Last Updated: 29 November, 2022