LabeledToggleProps Interface

Properties for LabeledToggle

Extends

Inherited methods

Name Inherited from Description
onBlur(event: FocusEvent<Element>): any Optional ToggleProps Function called when the toggle loses focus
onChange(checked: boolean): any Optional ToggleProps Function called when the toggle state is changed

Properties

Name Type Description
label undefined | string Text that will be shown next to the Toggle.  
labelClassName undefined | string Custom CSS class name for the label  
labelStyle undefined | CSSProperties Custom CSS Style for the label  

Inherited properties

Name Type Inherited from Description
buttonType undefined | ToggleButtonType ToggleProps Button type, either Primary or Blue (Blue is default)
className undefined | string ToggleProps Custom CSS class name
disabled undefined | boolean ToggleProps Indicates whether the Toggle is disabled (default is false)
isOn undefined | boolean ToggleProps Indicates whether the Toggle is "on" or "off" (default is false)
large undefined | boolean ToggleProps Use larger size (default is false)
ref undefined | Ref<HTMLInputElement> ToggleProps Provides ability to return reference to HTMLInputElement
rounded undefined | boolean ToggleProps Show the toggle rounded or square (rounded is default)
setFocus undefined | boolean ToggleProps Indicates whether to set focus to the input element
showCheckmark undefined | boolean ToggleProps Show a check mark icon when the toggle is "on" (false is default)
style undefined | CSSProperties ToggleProps Custom CSS style properties
title undefined | string ToggleProps Tooltip text

Defined in

Last Updated: 29 November, 2022