UiCore Class

Manages the I18N service for the ui-core package.

Methods

Name Description
constructor(): UiCore    
initialize(i18n: I18N): Promise<void> Static Registers the I18N service namespace for UiCore.  
terminate(): void Static Unregisters the UiCore I18N namespace  

Properties

Name Type Description
i18n Accessor StaticReadOnly I18N The internationalization service created by the application.  
i18nNamespace Accessor StaticReadOnly string The internationalization service namespace.  
initialized Accessor StaticReadOnly boolean Determines if UiCore has been initialized  

Defined in

Last Updated: 29 November, 2022