ChildWindowManager Class

Beta  

Supports opening a child browser window from the main application window. The child window is managed by the main application and is running in the same security context. The application must deliver the html file iTwinPopup.html along side its index.html. See also: Child Window Manager

Methods

Name Description
constructor(): ChildWindowManager    
closeAllChildWindows(): void Close all child/pop-out windows.  
closeChildWindow(childWindowId: string, processWindowClose: boolean = true): boolean    
findChildWindow(childWindowId: undefined | string): undefined | OpenChildWindowInfo    
findChildWindowId(contentWindow: undefined | | Window): undefined | string    
openChildWindow(childWindowId: string, title: string, content: ReactNode, location: ChildWindowLocationProps, useDefaultPopoutUrl?: boolean): boolean    

Properties

Name Type Description
openChildWindows Accessor ReadOnly OpenChildWindowInfo[]    

Defined in

Last Updated: 29 November, 2022