SavedViewLayout Class

SavedViewLayout class. Used to serialize/deserialize a View Layout with Saved Views.

Methods

Name Description
constructor(): SavedViewLayout    
emphasizeElementsFromProps(contentGroup: ContentGroup, savedProps: SavedViewLayoutProps): boolean Static Apply EmphasizeElements from the SavedView  
viewLayoutToProps(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup, emphasizeElements: boolean = false, contentCallback?: ContentCallback): SavedViewLayoutProps Static Create props for a View Layout  
viewStatesFromProps(iModelConnection: IModelConnection, savedProps: SavedViewLayoutProps): Promise<undefined | ViewState[]> Static Create an array of ViewStates from the SavedViewLayout  

Defined in

Last Updated: 29 November, 2022