FrontstageDef Class

FrontstageDef class provides an API for a Frontstage.

Methods

Name Description
constructor(props?: FrontstageProps): FrontstageDef Constructs the FrontstageDef  
_onActivated(): void Protected Handles when the Frontstage becomes activated  
_onDeactivated(): void Protected Handles when the Frontstage becomes inactive  
_onFrontstageReady(): void Protected Handles when the Frontstage becomes active  
dockWidgetContainer(widgetId: string): void Finds the container with the specified widget and re-docks all widgets Beta  
findWidgetDef(id: string): undefined | WidgetDef Finds a WidgetDef based on a given id  
floatWidget(widgetId: string, point?: PointProps, size?: SizeProps): void Create a new floating panel that contains the widget specified by its Id. Beta  
getStagePanelDef(location: StagePanelLocation): undefined | StagePanelDef Gets a StagePanelDef based on a given panel location Beta  
getZoneDef(zoneId: number): undefined | ZoneDef Gets a ZoneDef based on a given zone id  
initializeFromProvider(frontstageProvider: FrontstageProvider): void Initializes this FrontstageDef from a FrontstageProvider  
isFloatingWidget(widgetId: string): boolean    
isPopoutWidget(widgetId: string): boolean    
onActivated(): void Handles when the Frontstage becomes activated  
onDeactivated(): void Handles when the Frontstage becomes inactive  
onFrontstageReady(): void Handles when the Frontstage becomes active  
popoutWidget(widgetId: string, point?: PointProps, size?: SizeProps): void Create a new popout/child window that contains the widget specified by its Id. Beta  
restoreLayout(): void   Beta  
setActiveContent(): boolean Sets the active view content control to the default or first  
setActiveView(newContent: ContentControl, oldContent?: ContentControl): void Sets the active view content control  
setActiveViewFromViewport(viewport: ScreenViewport): boolean Sets the active view content control based on the selected viewport.  
setContentLayoutAndGroup(contentLayoutDef: ContentLayoutDef, contentGroup: ContentGroup): void Sets the Content Layout and Content Group  
startDefaultTool(): void Starts the default tool for the Frontstage  
waitUntilReady(): Promise<void> Returns once the contained widgets and content controls are ready to use  

Properties

Name Type Description
applicationData Accessor ReadOnly any    
bottomCenter Accessor ReadOnly undefined | ZoneDef    
bottomLeft Accessor ReadOnly undefined | ZoneDef    
bottomMostPanel Accessor ReadOnly undefined | StagePanelDef    
bottomPanel Accessor ReadOnly undefined | StagePanelDef    
bottomRight Accessor ReadOnly undefined | ZoneDef    
centerLeft Accessor ReadOnly undefined | ZoneDef    
centerRight Accessor ReadOnly undefined | ZoneDef    
contentControls Accessor ReadOnly ContentControl[] Gets the list of ContentControls  
contentGroup Accessor ReadOnly undefined | ContentGroup    
contentGroupId Accessor ReadOnly string    
contentLayoutDef Accessor ReadOnly undefined | ContentLayoutDef    
defaultContentId Accessor ReadOnly string    
defaultLayout Accessor ReadOnly undefined | ContentLayoutDef    
defaultLayoutId Accessor ReadOnly string    
defaultTool Accessor ReadOnly undefined | ToolItemDef    
frontstageProvider Accessor ReadOnly undefined | FrontstageProvider    
id Accessor ReadOnly string    
isApplicationClosing Accessor ReadOnly boolean    
isInFooterMode Accessor ReadOnly boolean    
isStageClosing Accessor ReadOnly boolean    
leftPanel Accessor ReadOnly undefined | StagePanelDef    
panelDefs Accessor ReadOnly StagePanelDef[] Gets a list of StagePanelDefs  
rightPanel Accessor ReadOnly undefined | StagePanelDef    
topCenter Accessor ReadOnly undefined | ZoneDef    
topLeft Accessor ReadOnly undefined | ZoneDef    
topMostPanel Accessor ReadOnly undefined | StagePanelDef    
topPanel Accessor ReadOnly undefined | StagePanelDef    
topRight Accessor ReadOnly undefined | ZoneDef    
usage Accessor ReadOnly string    
version Accessor ReadOnly number    
zoneDefs Accessor ReadOnly ZoneDef[] Gets a list of ZoneDefs  

Defined in

Last Updated: 29 November, 2022