StatusFieldProps Interface

Properties for a StatusBar field component

Extends

Methods

Name Description
onOpenWidget(widget: StatusBarFieldId): void Function called when the widget is opened or closed.  

Properties

Name Type Description
isInFooterMode boolean Indicates whether the StatusBar is in footer mode  
openWidget StatusBarFieldId Field Id for open widgets  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 29 November, 2022